gensokyo_kappa-overlay/sys-apps/cpupower-gui/cpupower-gui-0.6.2.ebuild
2021-02-10 14:29:47 +01:00

39 lines
718 B
Bash

# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="Simple GUI for cpupower"
HOMEPAGE="https://github.com/vagnum08/cpupower-gui/"
SRC_URI="https://github.com/vagnum08/cpupower-gui/archive/v${PV}.zip -> ${P}.zip"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="nls"
RDEPEND=">=x11-libs/gtk+-3.0
sys-apps/dbus
>=dev-lang/python-3
sys-auth/polkit
dev-python/dbus-python
nls? ( sys-devel/gettext )"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}-${PV}
src_prepare() {
default
eautoreconf
}
src_configure() {
econf --disable-silent-rules $(use_enable nls)
}
src_install() {
emake DESTDIR="${D}" install
}