gensokyo_kappa-overlay/net-im/bitlbee-discord/bitlbee-discord-0.4.2.ebuild
2021-02-10 14:29:47 +01:00

38 lines
613 B
Bash

# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=7
inherit autotools git-r3
DESCRIPTION="Discord protocol plugin for bitlbee."
HOMEPAGE="https://github.com/sm00th/bitlbee-discord"
MY_AUTHOR="sm00th"
EGIT_REPO_URI="https://github.com/${MY_AUTHOR}/${PN}.git"
if [[ ${PV} == "9999" ]] ; then
EGIT_BRANCH="master"
KEYWORDS=""
else
EGIT_COMMIT="${PV}"
KEYWORDS="~x86 ~amd64"
fi
LICENSE="GPL-2"
SLOT="0"
IUSE=""
IUSE+=""
DEPEND="
dev-libs/glib
net-im/bitlbee"
RDEPEND="${DEPEND}"
src_prepare() {
default
eautoreconf
}