gensokyo_kappa-overlay/dev-util/meta-casio/meta-casio-9999.ebuild

28 lines
956 B
Bash

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="A meta package that installs Lephenixnoir's fxSDK and add-ins wrapper"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="dev-util/g1a-wrapper
dev-util/fxsdk"
RDEPEND="${DEPEND}"
BDEPEND=""
S="${WORKDIR}/add-in-wrapper/"
pkg_postinst() {
ewarn "To compile software for calculator, you will need to install crossdev"
ewarn "to do so, run emerge --ask crossdev"
ewarn "then, you will need gcc, choose a target that suits for your calculator"
ewarn " - \"sh3eb-elf\" for SH3 and SH4 Monochrome casio calculators"
ewarn " - \"sh4eb-nofpu-elf\" for GRAPH 90+E or others specific uses"
ewarn "run crossdev --target <target>"
ewarn "it is normal that newlib won't compile, more info on the following link"
ewarn "https://www.planet-casio.com/Fr/forums/topic15316-1-Complete-C-standard-library.html"
}