OI/games-action/minecraft-launcher/minecraft-launcher-9999.ebuild
2019-05-05 00:18:02 +02:00

30 lines
679 B
Bash

# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit desktop
DESCRIPTION="The official Minecraft launcher"
HOMEPAGE="https://www.minecraft.net/fr-fr/download/alternative/"
SRC_URI="https://launcher.mojang.com/download/Minecraft.tar.gz"
LICENSE=""
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="~virtual/jre-1.8.0"
RDEPEND="${DEPEND}"
BDEPEND=""
S="${WORKDIR}/minecraft-launcher"
src_install() {
dodir /opt/${PN}
insinto /opt/${PN}
doins -r *
fperms +x /opt/${PN}/minecraft-launcher
dosym /opt/${PN}/minecraft-launcher /usr/bin/${PN}
make_desktop_entry "/usr/bin/minecraft-launcher" "Minecraft Launcher"
}